51 lines
1.4 KiB
Nix
51 lines
1.4 KiB
Nix
{
|
|
inputs = {
|
|
nixpkgs.url = "https://flakehub.com/f/NixOS/nixpkgs/0.1.0.tar.gz";
|
|
devenv.url = "github:cachix/devenv";
|
|
};
|
|
|
|
nixConfig = {
|
|
extra-trusted-public-keys = "devenv.cachix.org-1:w1cLUi8dv3hnoSPGAuibQv+f9TZLr6cv/Hm9XgU50cw=";
|
|
extra-substituters = "https://devenv.cachix.org";
|
|
};
|
|
|
|
outputs = {
|
|
self,
|
|
nixpkgs,
|
|
devenv,
|
|
systems,
|
|
...
|
|
} @ inputs: let
|
|
forEachSystem = nixpkgs.lib.genAttrs (import systems);
|
|
in {
|
|
devShells =
|
|
forEachSystem
|
|
(system: let
|
|
pkgs = nixpkgs.legacyPackages.${system};
|
|
in {
|
|
default = devenv.lib.mkShell {
|
|
inherit inputs pkgs;
|
|
modules = [
|
|
{
|
|
# https://devenv.sh/reference/options/
|
|
packages = [pkgs.git pkgs.ttfautohint-nox];
|
|
languages.javascript.enable = true;
|
|
|
|
scripts."build-super-ttc".exec = ''
|
|
git clone --single-branch --depth=1 https://github.com/be5invis/Iosevka || pushd Iosevka && git pull && popd
|
|
cp private-build-plans.toml ./Iosevka
|
|
|
|
pushd ./Iosevka
|
|
npm install
|
|
npm run build -- super-ttc::iosevka-acicchetti
|
|
|
|
mv dist/.super-ttc/iosevka-acicchetti.ttc ../iosevka-acicchetti-$(date -I).ttc
|
|
popd
|
|
rm -rf ./Iosevka
|
|
'';
|
|
}
|
|
];
|
|
};
|
|
});
|
|
};
|
|
}
|